Hi All,


Since the last 2 updates my meter has been playing up a fair bit.. As i noticed i was getting alot of timeout errors with Home Assistant.

I have tried a whole bunch of multiple things to try and get the system working again. I have rebooted, power cycled. Factory Reset, and also upgraded the firmware again but it hasn't fixed the problem.


The timeouts occur with Ping, WWW and Home assistant... Has anybody else had any similar problems?

It does still seem to be able to upload the data to the Iammeter cloud system..


I was running 2.75.92 until the newer version came out and i am currently running firmware i.75.96

(However this problem only started when i upgrade to 2.75.92)


Logger: homeassistant.components.iammeter.sensor
Source: components/iammeter/sensor.py:58
Integration: iammeter (documentationissues)
First occurred: 3:24:28 PM (1 occurrences)
Last logged: 3:24:28 PM

Device is not ready



Reply from 10.50.5.196: bytes=32 time=20ms TTL=254
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 10.50.5.196: bytes=32 time=24ms TTL=254
Request timed out.
Request timed out.
Reply from 10.50.5.196: bytes=32 time=3ms TTL=254
Request timed out.
Request timed out.
Reply from 10.50.5.196: bytes=32 time=38ms TTL=254
Request timed out.

Thread Status
9
134
2
0
0

Sort replies by:

Is anyone else also found this problem?


About nedwos`s question ,please help me to confirm such issues below,+

1 The timeouts occur with Ping, WWW and Home assistant... Has anybody else had any similar problems?

please let me know what means "www and home assistant"? you just ping the IP of the energy meter,and found it usually timeout, yes?


2 what is the difference in your usage between the version of 76 and 96?

If you use the energy meter in Home assistant,the 76 version only supports IAMMETER integration while the 96 version supports modbus/tcp sensor.
Whether you use the modbus/tcp to request the data in Home assistant after the upgrading? if so ,what is the frequency?

Or you still use the IAMMETER integration even after the upgrading? 

Hi All,Since the last 2 updates my meter has been playing up a fair bit.. As i noticed i was getting alot of timeout errors with Home Assistant.I have tried a whole bunch of multiple things to try and get the system working again. I have rebooted, power cycled. Factory Reset, and also upgraded the firmware again but it hasn't fixed the problem.The timeouts occur with Ping, WWW and Home assistant... Has anybody else had any similar problems?It does still seem to be able to upload the data to the

The timeouts occur as illustrated by 

Ping - As you can see it stops responding

WWW - When i try and goto the management interface it times out sometimes (Won't load) i have to hit refresh and wait a long time

Home assistant - Again as illustrated (in my first post is HA stating the device isn't ready), I am using the standard intergration with Home Assistant to read the values (Not using modbus/tcp etc) 


I usually like to keep my devices updates which is why i am running the latest version (No real reason for upgrading)

Is anyone else also found this problem?About nedwos`s question ,please help me to confirm such issues below,+1 The timeouts occur with Ping, WWW and Home assistant... Has anybody else had any similar problems?please let me know what means "www and home assistant"? you just ping the IP of the energy meter,and found it usually timeout, yes?2 what is the difference in your usage between the version of 76 and 96?If you use the energy meter in Home assistant,the 76 version only supports IAMMETER

Logger: homeassistant.components.iammeter.sensor
Source: helpers/update_coordinator.py:237
Integration: iammeter (documentationissues)
First occurred: July 26, 2022 at 3:25:34 PM (881 occurrences)
Last logged: 7:58:18 PM

Error fetching IamMeter data:

The timeouts occur as illustrated by Ping - As you can see it stops respondingWWW - When i try and goto the management interface it times out sometimes (Won't load) i have to hit refresh and wait a long timeHome assistant - Again as illustrated (in my first post is HA stating the device isn't ready), I am using the standard intergration with Home Assistant to read the values (Not using modbus/tcp etc) I usually like to keep my devices updates which is why i am running the latest versio

Sorry, I am also confused and need to confirm again.

1 this is the local IP of the Wi-Fi energy meter ,yes?


2 What is the FW version before upgrading?

3 what is the run mode setting of the energy meter?  Cloud  ,tcp or HTTP ? 

If you upload data directly to your own system, what is the upload interval you had set?

By the way, from the ping result, even if it is not a timeout, the time is obviously too long.



This is the ping result from my side, it should be around 10ms.



Is there any network change recently?


Yes this is the local IP of the meter is 10.50.3.196

Firmware before updating was -: 2.75.92 (However this firmware has the same problems)

Run Mode: Cloud


Sorry, I am also confused and need to confirm again.1 this is the local IP of the Wi-Fi energy meter ,yes?2 What is the FW version before upgrading?3 what is the run mode setting of the energy meter?  Cloud  ,tcp or HTTP ? If you upload data directly to your own system, what is the upload interval you had set?

No Network changes recently...

Only change has been the Firmware upgrade


Can i go backwards in firmware? Are you able to link to the firmware BEFORE 2.75.92

By the way, from the ping result, even if it is not a timeout, the time is obviously too long.This is the ping result from my side, it should be around 10ms.Is there any network change recently?

Any response? Are you able to post links to the previous Firmware releases? Am i able to go back before 2.75.92??

This is the 2.75.76 version

75.76

But I do not think this problem has been caused by the firmware upgrading.

Please let me know whether it is resolved after the FW downward upgrade

Looks like you are new here. Register for free, learn and contribute.