Troubleshooting: Fix the possible problem in NEM(net energy metering) mode

There is no data display in the overview page

    Possible reason

    why it occurs

    How to fix

The historical kWh data is lost in the overview dashboard

    Possible reason

    why it occurs

    How to fix   

How to set the NEM(Net energy metering mode) 

    Call the local API of the energy meter, enable it output the net metering measurement result

    Choose the "NEM" mode in IAMMETER`s system

There is no data display in the overview page

The uploading is continued,but there is no data display in the overview dashboard.

Possible reason

You just select the "NEM" mode in the IAMMETER but have not called the local API to enable the NEM result output.

image-20220722105405290

why it occurs

Only after the local API had been called, there will be a NEM result in the output of the energy meter(the fourth column data). After you select the NEM mode in IAMMETER, it will use the fourth column data to calculate the kwh .

If you had not called the local API at this time, the measurement result will not include the fourth column data. So there is no valid data can be used to calculated the kWh in the overview dashboard.

How to fix

Calling the local API to enable the Net metering mode result of the 3 phase energy meter

Call the local API of the energy meter, enable it output the net metering measurement result

 

The historical kWh data is lost in the overview dashboard

Possible reason

You click the " Recalculate historical bills after saving" on the edit page of the place after you set the NEM mode in IAMMETER.

why it occurs

The energy meter had run for some time in normal mode (not NEM mode). Then your system switch to NEM mode, so you also want to switch your energy meter into NEM mode. But there is no NEM result in the historical data. So if you click " Recalculate historical bills after saving" after you switch the IAMMETER from NORMAL to NEM, IAMMETER will try to use the fourth column data to calculate the historical kwh data, but there is no fourth column in the historical record.

How to fix

  1. Change back to normal mode
  2. click " Recalculate historical bills after saving",then the IAMMETER will calculate the historical kwh by the 3 phase energy data (not NEM result), so the historical result would be restored.
  3. set "NEM mode" again (please make sure you have called the local API to enable the NEM measurement now )

Please do not click " Recalculate historical bills after saving" anymore after you switch the mode to "NEM"

QQ截图20220722094611

 

 

How to set the NEM(Net energy metering mode)

Tutorial :How to set the NEM mode in the IAMMETER

Please note, it includes two steps

Call the local API of the energy meter, enable it output the net metering measurement result

Before the calling of this API, there are only three columns of data that represent each phase of the 3 phase system. After the calling, there would be a fourth column, that represents the net energy metering result of the 3 phase system.

enable the energy meter to output the NEM measurement result

Choose the "NEM" mode in IAMMETER`s system

choose the "NEM" mode in IAMMETER`s system

Thread Status
0
62
1
0
0

Sort replies by:
Looks like you are new here. Register for free, learn and contribute.