Docker app needs better data validation for pvoutput.org

I had this error today in the docker app logs many times so no data is being sent to pvoutput.org


[05:40:06 INF] pvoutput upload error:Bad request 400: Invalid energy value [-417105]; data:{"d":"20220618","t":"05:39","v1":-417.1050,"v2":0.0,"v3":-441.3560,"v4":592.0,"v6":0.0,"n":null,"APIKey":"xxxxxx","SystemId":"xxxx"} 


This could have been because of bad data at my end as I only got my meter going today so lots of trial and error getting things right....

They say -47105 and we say -47.1050 which looks suspect to me. Maybe there is a language  encoding error. I suspect it is because they don't expect negative values.

Thread Status
3
26
2
0
0

Sort replies by:

1 please upgrade the firmware of the energy meter to the latest version 2.75.92

https://imeter.club/topic/11

2 The V1 is the daily solar pv generation.

please note, that the unit is wh, not the kwh.

Definition of V1 :https://pvoutput.org/help/api_specification.html#id2

and https://forum.pvoutput.org/t/need-clarification-on-v1-v4-parameters/197

3 I also do not know why the error log of pvoutput said  "Invalid energy value [-417105]" but the real value in the log is -417.05.


The energy meter of IAMMETER does not have the output for the data of daily kwh.
So we calculated the daily kwh in this way(both IAMMETER-cloud and IAMMETER-docker both use this formula to calculate the daily kwh).
Daily kwh=the current kwh - the first kwh in this day.
Please check whether your installation may cause the negative value result in the above subtraction formula.
In fact, because the V1 unit is wh, not kwh, so this value is very small,(less than 1kw).


Thanks, I upgraded the meter's firmware.

The new day seemed to fix the issue BUT

I am now getting errors from pvoutput regarding moon power becasue of the use of UTC time instead of local time results in sending data before sunrise.

I will report back in the other time zone thread. I don't think its as simple as just changing the time zone in the docker as I have done that.

 

I think this is because you do not successfully set the TZ in the IAMMETER container.

My colleague had replied to you here https://imeter.club/topic/249


Thanks, I upgraded the meter's firmware.The new day seemed to fix the issue BUTI am now getting errors from pvoutput regarding moon power becasue of the use of UTC time instead of local time results in sending data before sunrise.I will report back in the other time zone thread. I don't think its as simple as just changing the time zone in the docker as I have done that. 
Looks like you are new here. Register for free, learn and contribute.